Cisco IOS to Huawei cheat sheet commands

This is a quick reference guide detailing the equivillent commands in huawei compared to their Cisco IOS commands.

I have tried to add as many comparisons as possible from what I have accumulated over the years, for the most part the OS’ are similar but there are annoying differences that make it hard at times to know what the command is , especially if you are jumping between the two devices.

Anyway heres a comprehensive list in table format, hopefully it is usefull to some people as I find huawei docs very lacking …

Show commands

These show commands show the equivillent Huawei VRP command

Cisco IOS Command Huawei VRP Command Description
show version display version Show software version information.
show interface status display interface brief Show status of all interfaces.
show ip route display ip routing-table Show IP routing table.
show arp display arp Show ARP table.
show vlan display vlan Show VLAN information.
show mac address-table display mac-address Show MAC address table.
show access-lists display acl Show configured access control lists.
show ip dhcp pool display dhcp server Show DHCP pool information.
show ip ospf neighbor display ospf peer Show OSPF neighbor information.
show ip bgp summary display bgp peer Show BGP neighbor summary.
show ip nat translations display nat session Show NAT translation table.
show vlan interface display interface vlan Show VLAN interfaces.
show interfaces description display interface description Show interface descriptions.
show policy-map interface display qos interface Show QoS policy applied to interfaces.
show power inline display poe interface Show PoE status of interfaces.
show spanning-tree display stp brief Show STP information.
show standby display vrrp Show HSRP or VRRP status.
show etherchannel summary display link-aggregation summary Show EtherChannel summary.
show processes cpu display cpu-usage Show CPU utilization.
show vtp status display vtp status Show VTP status.
show ip nat statistics display nat statistics Show NAT statistics.
show ip policy display ip policy Show configured IP policy.
show ip sla configuration display ip sla configuration Show IP SLA configuration.
show port-security display port-security Show port security configuration.
show ntp status display ntp-service status Show NTP status.
show aaa display aaa Show AAA configuration.
`show interfaces include (CRC error)`
show vlan brief display vlan all Show VLAN information in brief.
show memory display memory Show memory usage.
show module display device Show module information.
show crypto isakmp sa display ike sa Show IPsec IKE SA information.
`show policy-map interface include queue` display qos queue-statistics interface
show ip protocols display ospf brief Show IP routing protocol summary.
show ipv6 interface display ipv6 interface Show IPv6 interface configuration.
show vlan access-map display vlan-acl Show VLAN access-map configuration.
show ip sla statistics display ip sla statistics Show IP SLA statistics.
show environment power display power Show power supply status.
show ip mroute display igmp multicast-route Show IP multicast routing table.
show crypto ipsec sa display ipsec sa Show IPsec SA information.
show mac-address-table aging-time display mac-address aging-time Show MAC address aging time.
show ip nat translations display nat session Show NAT translation table.
show vrf display vrf Show VRF configuration.
show vrrp display vrrp Show VRRP configuration.
show ip accounting display ip accounting Show IP accounting information.
show ip dhcp server statistics display dhcp server statistics Show DHCP server statistics.
show ip slb display slb Show SLB configuration.
show mpls display mpls Show MPLS configuration.
show ip verify source display ip verify source Show IP source guard configuration.
show ip route display ip routing-table Show IP routing table.
show bfd neighbors display bfd session Show BFD session information.

Configuration commands

These are Cisco -> Huawei configuration commands and a brief description, I have tried to add a broad range of commands, if you need any more then let me know.

Cisco IOS Command Huawei VRP Command Description
interface GigabitEthernet0/0 interface GigabitEthernet0/0/0 Access interface configuration.
ip address 192.168.1.1 255.255.255.0 ip address 192.168.1.1 24 Assign IP address and subnet mask.
hostname Router1 sysname Router1 Set device hostname.
enable secret MySecretPassword set super password MySecretPassword Set enable password.
username admin privilege 15 secret Pa$$w0rd local-user admin privilege level 15 Create a local user with privilege level.
ip route 0.0.0.0 0.0.0.0 192.168.1.254 ip route-static 0.0.0.0 0.0.0.0 192.168.1.254 Configure default route.
vlan 10 vlan batch 10 Create VLAN.
name Sales name Sales Assign name to VLAN.
interface Vlan10 interface Vlanif10 Configure VLAN interface.
ip address 192.168.10.1 255.255.255.0 ip address 192.168.10.1 24 Assign IP address to VLAN interface.
interface Loopback0 interface LoopBack0 Configure loopback interface.
ip address 10.0.0.1 255.255.255.255 ip address 10.0.0.1 32 Assign IP address to loopback interface.
router ospf 1 ospf Enable OSPF routing protocol.
network 192.168.1.0 0.0.0.255 area 0 area 0 Configure OSPF network.
router bgp 65000 bgp 65000 Enable BGP routing protocol.
neighbor 192.168.1.2 remote-as 65001 peer 192.168.1.2 as-number 65001 Configure BGP neighbor.
network 192.168.1.0 mask 255.255.255.0 network 192.168.1.0 mask 24 Configure BGP network.
ip nat inside source list NAT_POOL interface GigabitEthernet0/1 overload nat outbound 3000 interface GigabitEthernet0/1 Configure NAT overload.
ip access-list standard NAT_POOL acl number 3000 Configure NAT pool ACL.
permit 192.168.1.0 0.0.0.255 rule 5 permit source 192.168.1.0 0.0.0.255 Configure NAT pool ACL rule.
access-list 101 permit tcp any any eq 80 acl number 1011 Configure standard ACL for traffic filtering.
interface GigabitEthernet0/0 interface GigabitEthernet0/0/0 Access interface configuration.
ip access-group 101 in packet-filter 1011 inbound Apply ACL to interface for traffic filtering.
router bgp 65000 bgp 65000 Enable BGP routing protocol.
neighbor 192.168.1.2 remote-as 65001 peer 192.168.1.2 as-number 65001 Configure BGP neighbor.
network 192.168.1.0 mask 255.255.255.0 network 192.168.1.0 mask 24 Configure BGP network.
neighbor 192.168.1.2 prefix-list OUT out peer 192.168.1.2 policy apply ip-prefix OUT export Apply prefix-list to BGP neighbor for outbound filtering.
ip prefix-list OUT seq 5 permit 192.168.1.0/24 ip ip-prefix OUT permit 192.168.1.0 24 Define prefix-list to permit specific prefixes.
neighbor 192.168.1.2 route-map IN in peer 192.168.1.2 policy apply route-map IN import Apply route-map to BGP neighbor for inbound route manipulation.
route-map IN permit 10 route-policy IN permit node 10 Define route-map for inbound route manipulation.
match as-path 1 if-match as-path 1 Match AS-path in route-map.
set local-preference 200 apply local-preference 200 Set local preference value for BGP routes.
set as-path prepend 65000 apply as-path prepend 65000 Prepend AS-path in route-map.
ip as-path access-list 1 permit ^65000$ bgp as-path access-list 1 permit ^65000$ Define AS-path access-list to match specific AS-path.
route-map OUT permit 10 route-policy OUT permit node 10 Define route-map for outbound route manipulation.
match ip address prefix-list OUT if-match ip-prefix OUT Match prefix-list in route-map.
set as-path prepend 65000 apply as-path prepend 65000 Prepend AS-path in route-map.
set local-preference 200 apply local-preference 200 Set local preference value for BGP routes.
ip prefix-list OUT seq 5 permit 192.168.1.0/24 ip ip-prefix OUT permit 192.168.1.0 24 Define prefix-list to permit specific prefixes.
ip as-path access-list 1 permit ^65000$ bgp as-path access-list 1 permit ^65000$ Define AS-path access-list to match specific AS-path.
ip route 0.0.0.0 0.0.0.0 192.168.1.254 ip route-static 0.0.0.0 0.0.0.0 192.168.1.254 Configure default route.
route-map IN permit 10 route-policy IN permit node 10 Define route-map for inbound route manipulation.
match ip address prefix-list OUT if-match ip-prefix OUT Match prefix-list in route-map.
set as-path prepend 65000 apply as-path prepend 65000 Prepend AS-path in route-map.
set local-preference 200 apply local-preference 200 Set local preference value for BGP routes.
ip prefix-list OUT seq 5 permit 192.168.1.0/24 ip ip-prefix OUT permit 192.168.1.0 24 Define prefix-list to permit specific prefixes.
ip as-path access-list 1 permit ^65000$ bgp as-path access-list 1 permit ^65000$ Define AS-path access-list to match specific AS-path.
access-list 101 permit tcp any any eq 80 acl number 1011 Configure standard ACL for traffic filtering.
class-map match-all HTTP traffic classifier HTTP operator and Define QoS class-map for HTTP traffic.
match access-group 101 if-match acl 1011 Match traffic using ACL in class-map.
policy-map RATE_LIMIT qos policy RATE_LIMIT Define QoS policy-map for rate limiting.
class HTTP classifier HTTP behavior car cir 512 cbs 2048 green Apply class-map to QoS policy-map.
police 512000 conform-action transmit exceed-action drop car cir 512 cbs 2048 green Configure rate limiting for conforming traffic.
interface GigabitEthernet0/0 interface GigabitEthernet0/0/0 Access interface configuration.
service-policy input RATE_LIMIT qos apply policy RATE_LIMIT inbound Apply QoS policy to inbound traffic.
access-list 101 permit tcp any any eq 80 acl number 1011 Configure standard ACL for traffic filtering.
traffic classifier HTTP operator and traffic classifier HTTP operator and Define traffic classifier for HTTP traffic.
if-match acl 1011 if-match acl 1011 Match traffic using ACL in traffic classifier.
qos policy RATE_LIMIT qos policy RATE_LIMIT Define QoS policy for rate limiting.
classifier HTTP behavior car cir 512 cbs 2048 green classifier HTTP behavior car cir 512 cbs 2048 green Configure rate limiting for HTTP traffic.
car cir 512 cbs 2048 green car cir 512 cbs 2048 green Configure rate limiting parameters.
interface GigabitEthernet0/0 interface GigabitEthernet0/0/0 Access interface configuration.
qos apply policy RATE_LIMIT inbound qos apply policy RATE_LIMIT inbound Apply QoS policy to inbound traffic.
ip nat inside source list NAT_POOL interface GigabitEthernet0/1 overload nat outbound 3000 interface GigabitEthernet0/1 Configure NAT overload.
ip access-list standard NAT_POOL acl number 3000 Configure NAT pool ACL.
permit 192.168.1.0 0.0.0.255 rule 5 permit source 192.168.1.0 0.0.0.255 Define NAT pool ACL rule.
interface GigabitEthernet0/0 interface GigabitEthernet0/0/0 Access interface configuration.
ip nat inside nat outbound Enable NAT on inside interface.
interface GigabitEthernet0/1 interface GigabitEthernet0/0/1 Access interface configuration.
ip nat outside nat server global 202.100.100.1 inside 192.168.1.10 Enable NAT on outside interface.
ip nat inside source static 192.168.1.10 202.100.100.1 nat static global 202.100.100.1 inside 192.168.1.10 Configure static NAT mapping.
ip nat inside source list 1 interface GigabitEthernet0/1 overload nat outbound 3001 interface GigabitEthernet0/1 Configure NAT overload with ACL.
access-list 1 permit 192.168.1.0 0.0.0.255 acl number 3001 Define ACL for NAT overload.
interface GigabitEthernet0/0 interface GigabitEthernet0/0/0 Access interface configuration.
ip nat inside nat outbound Enable NAT on inside interface.
interface GigabitEthernet0/1 interface GigabitEthernet0/0/1 Access interface configuration.
ip nat outside nat server global 202.100.100.1 inside 192.168.1.10 Enable NAT on outside interface.
ip nat inside source static 192.168.1.10 202.100.100.1 nat static global 202.100.100.1 inside 192.168.1.10 Configure static NAT mapping.
ip nat inside source list 1 interface GigabitEthernet0/1 overload nat outbound 3001 interface GigabitEthernet0/1 Configure NAT overload with ACL.
access-list 1 permit 192.168.1.0 0.0.0.255 acl number 3001 Define ACL for NAT overload.
ip dhcp pool MY_POOL dhcp server ip-pool MY_POOL Create DHCP pool named MY_POOL.
network 192.168.1.0 255.255.255.0 network 192.168.1.0 mask 255.255.255.0 Specify network and subnet mask for DHCP pool.
default-router 192.168.1.1 gateway-list 192.168.1.1 Specify default gateway for DHCP clients.
dns-server 8.8.8.8 dns-list 8.8.8.8 Specify DNS server for DHCP clients.
lease 7 lease day 7 Specify lease duration for DHCP addresses.
ip dhcp excluded-address 192.168.1.1 dhcp server excluded-ip-address 192.168.1.1 Exclude specific IP address from DHCP pool.
interface GigabitEthernet0/0 interface GigabitEthernet0/0/0 Access interface configuration.
ip address 192.168.1.1 255.255.255.0 ip address 192.168.1.1 24 Assign IP address and subnet mask.
ip dhcp pool MY_POOL dhcp server ip-pool MY_POOL Create DHCP pool named MY_POOL.
network 192.168.1.0 255.255.255.0 network 192.168.1.0 mask 255.255.255.0 Specify network and subnet mask for DHCP pool.
default-router 192.168.1.1 gateway-list 192.168.1.1 Specify default gateway for DHCP clients.
dns-server 8.8.8.8 dns-list 8.8.8.8 Specify DNS server for DHCP clients.
lease 7 lease day 7 Specify lease duration for DHCP addresses.
ip dhcp excluded-address 192.168.1.1 dhcp server excluded-ip-address 192.168.1.1 Exclude specific IP address from DHCP pool.
interface GigabitEthernet0/0 interface GigabitEthernet0/0/0 Access interface configuration.
ip address 192.168.1.1 255.255.255.0 ip address 192.168.1.1 24 Assign IP address and subnet mask.
ip flow-export destination 192.168.1.10 9996 netstream destination 192.168.1.10 port 9996 Configure NetFlow export destination.
ip flow-export version 9 netstream version v9 Set NetFlow export version to version 9.
interface GigabitEthernet0/0 interface GigabitEthernet0/0/0 Access interface configuration.
ip flow ingress netstream sampler inbound Enable NetFlow on ingress traffic.
ip flow egress netstream sampler outbound Enable NetFlow on egress traffic.
interface GigabitEthernet0/0 interface GigabitEthernet0/0/0 Access interface configuration.
ip flow ingress netstream sampler inbound Enable NetFlow on ingress traffic.
ip flow egress netstream sampler outbound Enable NetFlow on egress traffic.
ip flow-export destination 192.168.1.10 9996 netstream destination 192.168.1.10 port 9996 Configure NetFlow export destination.
ip flow-export version 9 netstream version v9

Debug Commands

These are debug commands Cisco -> Huawei

Cisco IOS Command Huawei VRP Command Description
debug ppp authentication debug ppp negotiation Debug PPP authentication process.
debug ip dhcp server packet debug dhcp server packet Debug DHCP server packets.
debug ip nat debug nat Debug NAT translation.
debug ip icmp debug icmp Debug ICMP packets.
debug ip ospf adj debug ospf event Debug OSPF adjacency.
debug ip bgp updates debug bgp packet Debug BGP updates.
debug ip packet debug ip packet Debug IP packets.
debug ip tcp transaction debug tcp packet Debug TCP transactions.
debug ip dhcp snooping debug dhcp snooping Debug DHCP snooping process.
debug ip flow debug netstream packet Debug NetFlow traffic.
debug ppp negotiation debug ppp negotiation Debug PPP negotiation process.
debug ip routing debug ip routing Debug IP routing table updates.
debug ip cef debug ip cef Debug Cisco Express Forwarding (CEF) operation.
debug ip ospf packet debug ospf packet Debug OSPF packets.
debug ip bgp debug bgp event Debug BGP events.
debug ip udp debug udp packet Debug UDP packets.
debug ip dhcp conflict debug dhcp conflict Debug DHCP conflict resolution process.
debug ip nat translation debug nat mapping Debug NAT translations.
debug ip icmp error debug icmp error Debug ICMP error messages.
debug ip ospf hello debug ospf hello Debug OSPF hello packets.
debug ip bgp dampening debug bgp dampening Debug BGP dampening process.
debug ip tcp window-scale debug tcp window-scale Debug TCP window scale negotiation.
debug ip dhcp server events debug dhcp server events Debug DHCP server events.
debug ip nat detail debug nat verbose Debug NAT detailed information.
debug ip icmp trace debug icmp trace Debug ICMP trace packets.
debug ip ospf lsa debug ospf lsa Debug OSPF Link State Advertisement (LSA).
debug ip bgp filter-list debug bgp filter-list Debug BGP filter list application.
debug ip tcp adjust-mss debug tcp adjust-mss Debug TCP Maximum Segment Size (MSS) adjustment.
debug ip dhcp snooping packet debug dhcp snooping packet Debug DHCP snooping packets.
debug ip nat service debug nat service Debug NAT service translation.
debug ip ospf spf debug ospf spf Debug OSPF Shortest Path First (SPF) algorithm.
debug ip bgp update-group debug bgp update-group Debug BGP update group process.
debug ip tcp intercept debug tcp intercept Debug TCP intercept events.
debug ip dhcp server packet detailed debug dhcp server packet verbose Debug DHCP server packet details.

Operational commands

These are operational commands such as ping, traceroute ssh etc

Cisco IOS Command Huawei VRP Command Description
ping 192.168.1.1 ping 192.168.1.1 Send ICMP echo request to specified IP address.
ping 192.168.1.1 source GigabitEthernet0/0 ping -c 4 192.168.1.1 Send ICMP echo request from specific interface.
traceroute 192.168.1.1 tracert 192.168.1.1 Trace route to specified IP address.
traceroute 192.168.1.1 source GigabitEthernet0/0 tracert -s 192.168.1.1 192.168.1.1 Trace route from specific interface.
ssh username@192.168.1.1 ssh -l username 192.168.1.1 Initiate SSH connection to specified host.
telnet 192.168.1.1 telnet 192.168.1.1 Initiate Telnet connection to specified host.
show interfaces display interface Show interface status and configuration.
show ip route display ip routing-table Display IP routing table.
show arp display arp Display ARP table.
show running-config display current-configuration Display current configuration.
show version display version Display device version information.
show ip interface brief display ip interface brief Display brief IP interface information.
show ip bgp summary display bgp peer Display BGP peer summary.
show ip ospf neighbor display ospf peer Display OSPF neighbor information.
show ip dhcp pool display dhcp server configuration Display DHCP pool configuration.
show ip nat translations display nat session all Display NAT translations.
show ip cef display cef Display Cisco Express Forwarding (CEF) status.
show ip accounting display accounting Display IP accounting information.
show ip sla statistics display ip sla Display IP SLA statistics.
show ip traffic display traffic-statistics Display IP traffic statistics.
show ip dhcp binding display dhcp server binding Display DHCP bindings.
show ip route ospf display ospf routing Display OSPF routing table.
show ip bgp display bgp routing-table Display BGP routing table.
show ip ospf database display ospf database Display OSPF database information.
show ip nat statistics display nat statistics Display NAT statistics.
show ip route summary display ip routing-table summary Display summary of IP routing table.
show ip dhcp conflict display dhcp conflict Display DHCP conflicts.
show ip nat translations verbose display nat session verbose Display detailed NAT translations.
show ip dhcp snooping display dhcp snooping Display DHCP snooping information.
show ip ospf interface display ospf interface Display OSPF interface information.

Device maintenance (E.g. firmare etc) commands

Commands for managing the device OS and firmware etc

Category Cisco IOS Command Huawei VRP Command Description
Firmware Management copy tftp flash ftp 10.1.1.1 get vrprunning.cfg Copy firmware from TFTP server to device.
archive download-sw load saved-configuration from ftp://10.1.1.1/vrprunning.cfg Load firmware from FTP server to device.
show version display version Display device version information.
Hardware Diagnostics show environment display environment Display hardware environment status.
show diag display device Display device hardware information.
show inventory display inventory Display device inventory information.
Power Management power inline display poe Display PoE (Power over Ethernet) status.
power inline consumption display poe interface Display PoE consumption on interfaces.
power inline auto poe enable Enable PoE globally.
Device Health Monitoring show processes cpu display cpu-usage Display CPU usage statistics.
show processes memory display memory Display memory usage statistics.
show interfaces status display interface brief Display brief interface status.
show logging display logbuffer Display system logs.
show tech-support display diagnostic-information Display detailed diagnostic information.
Configuration Management show running-config display current-configuration Display current configuration.
show startup-config display saved-configuration Display saved configuration.
copy running-config startup-config save Save current configuration.
write memory save force Save configuration forcefully.
write erase delete saved-configuration Delete saved configuration.
reload reboot Reload device.
configure terminal system-view Enter global configuration mode.

System maintenance commands

Commands to get system info and manage it etc

Category Cisco IOS Command Huawei VRP Command Description
System Information show version display version Display device version information.
show inventory display inventory Display device inventory information.
show module display device Display installed modules and hardware.
show chassis detail display device Display detailed chassis information.
System Status show environment display environment Display environmental status (temperature, etc.).
show processes cpu display cpu-usage Display CPU usage statistics.
show processes memory display memory Display memory usage statistics.
show interfaces status display interface brief Display brief interface status.
show logging display logbuffer Display system logs.
show tech-support display diagnostic-information Display detailed diagnostic information.
System Configuration show running-config display current-configuration Display current configuration.
show startup-config display saved-configuration Display saved configuration.
copy running-config startup-config save Save current configuration.
write memory save force Save configuration forcefully.
write erase delete saved-configuration Delete saved configuration.
reload reboot Reload device.
configure terminal system-view Enter global configuration mode.
System Monitoring show clock display clock Display system time.
show version display version Display device version information.
show processes cpu display cpu-usage Display CPU usage statistics.
show processes memory display memory Display memory usage statistics.
show interfaces display interface Display interface status and statistics.
show environment display environment Display environmental status.
show logging display logbuffer Display system logs.
show tech-support display diagnostic-information Display detailed diagnostic information.
System Backup and Restore copy running-config tftp save configuration to-file tftp:// Backup running configuration to TFTP server.
copy startup-config tftp save configuration to-file tftp:// Backup startup configuration to TFTP server.
copy tftp running-config load saved-configuration from ftp:// Restore configuration from TFTP server.
copy tftp startup-config load saved-configuration from ftp:// Restore configuration from TFTP server.

VRF Show commands

Commands when a vrf / namespace is required

Category Cisco IOS Command Huawei VRP Command Description
VRF Information show vrf display ip vpn-instance Display information about configured VRFs.
show ip vrf display ip vpn-instance Display detailed information about VRFs.
VRF Route Table show ip route vrf [VRF_NAME] display ip routing-table vpn-instance [VRF_NAME] Display route table for a specific VRF.
show ip bgp vpnv4 vrf [VRF_NAME] display bgp vpnv4 routing-table vpn-instance [VRF_NAME] Display BGP VPNv4 route table for a VRF.
show ip ospf vrf [VRF_NAME] neighbor display ospf peer vpn-instance [VRF_NAME] Display OSPF neighbors for a VRF.
show ip mroute vrf [VRF_NAME] display multicast routing-table vpn-instance [VRF_NAME] Display multicast route table for a VRF.
VRF Interface show ip interface vrf [VRF_NAME] display interface vpn-instance [VRF_NAME] Display interfaces associated with a VRF.
show ip ospf vrf [VRF_NAME] interface display ospf interface brief vpn-instance [VRF_NAME] Display OSPF interfaces associated with a VRF.
show ip bgp vpnv4 all labels vrf [VRF_NAME] display bgp vpnv4 peer [PEER_ADDRESS] vrf [VRF_NAME] Display VPNv4 BGP labels for a VRF.
VRF Traffic Statistics show ip traffic vrf [VRF_NAME] display traffic-statistics vpn-instance [VRF_NAME] Display traffic statistics for a VRF.
show ip ospf vrf [VRF_NAME] traffic display ospf traffic vpn-instance [VRF_NAME] Display OSPF traffic statistics for a VRF.
show ip bgp vpnv4 vrf [VRF_NAME] statistics display bgp vpnv4 statistics vpn-instance [VRF_NAME] Display BGP VPNv4 statistics for a VRF.
VRF Connectivity ping vrf [VRF_NAME] [IP_ADDRESS] ping vpn-instance [VRF_NAME] [IP_ADDRESS] Perform ping from a specific VRF.
traceroute vrf [VRF_NAME] [IP_ADDRESS] tracert vpn-instance [VRF_NAME] [IP_ADDRESS] Perform traceroute from a specific VRF.
telnet vrf [VRF_NAME] [DEVICE_IP] telnet vpn-instance [VRF_NAME] [DEVICE_IP] Initiate Telnet connection from a specific VRF.
ssh -l [USERNAME] vrf [VRF_NAME] [DEVICE_IP] ssh -l [USERNAME] vpn-instance [VRF_NAME] [DEVICE_IP] Initiate SSH connection from a specific VRF.

Clear commands

Clear commands to clear counters etc

Category Cisco IOS Command Huawei VRP Command Description
Clear BGP Sessions clear ip bgp [ADDRESS_FAMILY] * [VRF_NAME] reset bgp vpn-instance [VRF_NAME] Clear BGP sessions for a specific VRF.
Clear OSPF Sessions clear ip ospf process [PROCESS_ID] vrf [VRF_NAME] reset ospf vpn-instance [VRF_NAME] Clear OSPF sessions for a specific VRF.
Clear IP Route clear ip route vrf [VRF_NAME] * reset ip routing-table vpn-instance [VRF_NAME] Clear IP routes for a specific VRF.
Clear Interface clear ip ospf process [PROCESS_ID] vrf [VRF_NAME] interface [INTERFACE_NAME] reset ospf vpn-instance [VRF_NAME] interface [INTERFACE_NAME] Clear OSPF process for a specific interface in a VRF.
Clear ARP Cache clear ip arp vrf [VRF_NAME] * reset arp vpn-instance [VRF_NAME] Clear ARP cache for a specific VRF.
Clear BGP Route clear ip bgp [ADDRESS_FAMILY] [PREFIX] vrf [VRF_NAME] soft reset bgp vpn-instance [VRF_NAME] route [PREFIX] Clear BGP routes for a specific prefix in a VRF (soft).
reset bgp vpn-instance [VRF_NAME] route [PREFIX] hard Clear BGP routes for a specific prefix in a VRF (hard).
Clear NAT Translation clear ip nat translation vrf [VRF_NAME] * reset nat vpn-instance [VRF_NAME] Clear NAT translations for a specific VRF.
Clear Multicast Route clear ip mroute vrf [VRF_NAME] * reset multicast routing-table vpn-instance [VRF_NAME] Clear multicast routes for a specific VRF.
Clear DHCP Leases clear ip dhcp binding vrf [VRF_NAME] * reset dhcp server binding vpn-instance [VRF_NAME] Clear DHCP leases for a specific VRF.
Clear IP Accounting clear ip accounting vrf [VRF_NAME] reset accounting vpn-instance [VRF_NAME] Clear IP accounting data for a specific VRF.
Clear VRF clear ip vrf [VRF_NAME] reset ip vpn-instance [VRF_NAME] Clear all data associated with a specific VRF, including routes, interfaces, and configurations.
Clear OSPF Process clear ip ospf process [PROCESS_ID] vrf [VRF_NAME] reset ospf vpn-instance [VRF_NAME] process Clear OSPF process for a specific VRF, including neighbor adjacencies.
Clear BGP Soft Inbound clear ip bgp [ADDRESS_FAMILY] soft in vrf [VRF_NAME] reset bgp vpn-instance [VRF_NAME] inbound soft Clear BGP soft inbound routes for a specific VRF.
Clear BGP Soft Outbound clear ip bgp [ADDRESS_FAMILY] soft out vrf [VRF_NAME] reset bgp vpn-instance [VRF_NAME] outbound soft Clear BGP soft outbound routes for a specific VRF.
Clear BGP Hard Inbound clear ip bgp [ADDRESS_FAMILY] hard in vrf [VRF_NAME] reset bgp vpn-instance [VRF_NAME] inbound hard Clear BGP hard inbound routes for a specific VRF.
Clear BGP Hard Outbound clear ip bgp [ADDRESS_FAMILY] hard out vrf [VRF_NAME] reset bgp vpn-instance [VRF_NAME] outbound hard Clear BGP hard outbound routes for a specific VRF.
Clear BGP Soft Inbound Route-map clear ip bgp [ADDRESS_FAMILY] soft in route-map [ROUTE_MAP_NAME] vrf [VRF_NAME] reset bgp vpn-instance [VRF_NAME] inbound soft route-map [ROUTE_MAP_NAME] Clear BGP soft inbound routes matched by a route-map for a specific VRF.
Clear BGP Soft Outbound Route-map clear ip bgp [ADDRESS_FAMILY] soft out route-map [ROUTE_MAP_NAME] vrf [VRF_NAME] reset bgp vpn-instance [VRF_NAME] outbound soft route-map [ROUTE_MAP_NAME] Clear BGP soft outbound routes matched by a route-map for a specific VRF.
Clear BGP Hard Inbound Route-map clear ip bgp [ADDRESS_FAMILY] hard in route-map [ROUTE_MAP_NAME] vrf [VRF_NAME] reset bgp vpn-instance [VRF_NAME] inbound hard route-map [ROUTE_MAP_NAME] Clear BGP hard inbound routes matched by a route-map for a specific VRF.
Clear BGP Hard Outbound Route-map clear ip bgp [ADDRESS_FAMILY] hard out route-map [ROUTE_MAP_NAME] vrf [VRF_NAME] reset bgp vpn-instance [VRF_NAME] outbound hard route-map [ROUTE_MAP_NAME] Clear BGP hard outbound routes matched by a route-map for a specific VRF.
Clear BGP Prefix clear ip bgp [ADDRESS_FAMILY] [PREFIX] vrf [VRF_NAME] reset bgp vpn-instance [VRF_NAME] prefix [PREFIX] Clear BGP routes for a specific prefix in a VRF.
Clear BGP Neighbor clear ip bgp [ADDRESS_FAMILY] [NEIGHBOR_IP] vrf [VRF_NAME] reset bgp vpn-instance [VRF_NAME] neighbor [NEIGHBOR_IP] Clear BGP neighbor session for a specific VRF.
Clear BGP Peer-group clear ip bgp peer-group [PEER_GROUP_NAME] vrf [VRF_NAME] reset bgp vpn-instance [VRF_NAME] peer-group [PEER_GROUP_NAME] Clear BGP peer-group sessions for a specific VRF.
Clear BGP Update clear ip bgp [ADDRESS_FAMILY] [UPDATE_SOURCE] update vrf [VRF_NAME] reset bgp vpn-instance [VRF_NAME] update source [UPDATE_SOURCE] Clear BGP update for a specific VRF.
Clear Interface Counters clear counters vrf [VRF_NAME] [INTERFACE_NAME] reset interface counters vpn-instance [VRF_NAME] [INTERFACE_NAME] Clear interface counters for a specific VRF.
Clear VLAN Interface clear vlan vrf [VRF_NAME] [INTERFACE_NAME] N/A Clear VLAN interface settings for a specific VRF.
Clear MPLS Forwarding Table clear mpls forwarding vrf [VRF_NAME] reset mpls vpn-instance [VRF_NAME] Clear MPLS forwarding table for a specific VRF.
Clear MPLS LDP Neighbor clear mpls ldp neighbor vrf [VRF_NAME] [NEIGHBOR_ADDRESS] reset mpls ldp vpn-instance [VRF_NAME] [NEIGHBOR_ADDRESS] Clear MPLS LDP neighbor for a specific VRF.
Clear MPLS Traffic Engineering clear mpls traffic-eng vrf [VRF_NAME] reset mpls traffic-eng vpn-instance [VRF_NAME] Clear MPLS Traffic Engineering database for a specific VRF.
Clear PIM Neighbor clear ip pim vrf [VRF_NAME] neighbor [NEIGHBOR_ADDRESS] reset pim vpn-instance [VRF_NAME] neighbor [NEIGHBOR_ADDRESS] Clear PIM neighbor for a specific VRF.
Clear DHCP Server Lease clear ip dhcp server vrf [VRF_NAME] * reset dhcp server database vpn-instance [VRF_NAME] Clear DHCP server lease database for a specific VRF.
Clear IPsec SA clear crypto ipsec sa vrf [VRF_NAME] [PEER_ADDRESS] reset ipsec sa vpn-instance [VRF_NAME] [PEER_ADDRESS] Clear IPsec Security Associations for a specific VRF.
Clear VRF Definition no vrf definition [VRF_NAME] undo vpn-instance [VRF_NAME] Remove the definition of a specific VRF.

IPSEC Commands (Config, Show & Debug)

Commands for IPSec VPNS

Category Cisco IOS Command Huawei VRP Command Description
Configuration
IKE Phase 1
crypto isakmp policy ike peer Configure IKE Phase 1 policy.
crypto isakmp key ike peer Configure pre-shared key for IKE Phase 1.
crypto isakmp identity ike peer Configure IKE Phase 1 identity method.
IKE Phase 2
crypto ipsec transform-set ipsec transform-set Configure IPsec transform set.
crypto map ipsec policy Create crypto map for IPsec Phase 2.
crypto dynamic-map Configure dynamic crypto map.
IPsec Peer
crypto map ike peer Apply crypto map to an interface.
crypto isakmp profile ike peer Configure IKE Phase 1 profile.
Tunnel Interface
interface tunnel interface tunnel Create tunnel interface.
tunnel protection ipsec profile ike-profile Apply IPsec profile to tunnel interface.
Show Commands
IKE Phase 1 Information
show crypto isakmp sa display ike sa Display IKE Phase 1 security associations.
show crypto isakmp policy display ike proposal Display IKE Phase 1 policy.
IKE Phase 2 Information
show crypto ipsec sa display ipsec sa Display IPsec Phase 2 security associations.
show crypto map Display configured crypto maps.
IPsec Peer Information
show crypto isakmp peer display ike peer Display IKE Phase 1 peer information.
show crypto map Display configured crypto maps.
IPsec Configuration
`show run section crypto` `display current-configuration configuration
show crypto engine connections active Display active IPsec connections.
Clear Commands
Clear IKE/IPsec
clear crypto isakmp reset ike Clear IKE sessions and SA.
clear crypto ipsec reset ipsec Clear IPsec sessions and SA.
Debug Commands
Debug IKE/IPsec
debug crypto isakmp debug ike Enable IKE debugging.
debug crypto ipsec debug ipsec Enable IPsec debugging.

Debug commands

Commands for debugging

Category Cisco IOS Command Huawei VRP Command Description
General Debugging
debug ? debug ? Display available debug options.
debug all debug all Enable all debugging.
ARP Debugging
debug arp debug arp Enable ARP debugging.
BGP Debugging
debug ip bgp debug bgp Enable BGP debugging.
EIGRP Debugging
debug eigrp debug eigrp Enable EIGRP debugging.
OSPF Debugging
debug ip ospf debug ospf Enable OSPF debugging.
RIP Debugging
debug ip rip debug rip Enable RIP debugging.
HSRP Debugging
debug standby debug hsrp Enable HSRP debugging.
VRRP Debugging
debug vrrp debug vrrp Enable VRRP debugging.
ACL Debugging
debug ip packet debug acl Enable ACL debugging.
NAT Debugging
debug ip nat debug nat Enable NAT debugging.
IPsec Debugging
debug crypto isakmp debug ike Enable IKE debugging.
debug crypto ipsec debug ipsec Enable IPsec debugging.
Multicast Debugging
debug ip multicast debug multicast Enable multicast debugging.
QoS Debugging
debug qos debug qos Enable QoS debugging.
NTP Debugging
debug ntp debug ntp-service Enable NTP debugging.
DHCP Debugging
debug dhcp debug dhcp Enable DHCP debugging.
Spanning Tree Debugging
debug spanning-tree debug stp Enable Spanning Tree Protocol debugging.
VLAN Debugging
debug vlan debug vlan Enable VLAN debugging.
AAA Debugging
debug aaa debug aaa Enable AAA debugging.
Firewall Debugging
debug firewall debug firewall Enable firewall debugging.
Syslog Debugging
debug syslog debug log Enable syslog debugging.
SNMP Debugging
debug snmp debug snmp-agent Enable SNMP debugging.
VRF Debugging
debug ip routing debug routing Enable VRF routing debugging.
MPLS Debugging
debug mpls debug mpls Enable MPLS debugging.
IP SLA Debugging
debug ip sla debug ip-service Enable IP SLA debugging.

Spanning tree commands

Spanning tree commands, show and configure

Category Cisco IOS Command Huawei VRP Command Description
Show Commands
show spanning-tree display stp Display spanning tree information.
show spanning-tree vlan [VLAN] display stp vlan [VLAN] Display spanning tree information for a specific VLAN.
show spanning-tree interface [INTERFACE] display interface [INTERFACE] stp Display spanning tree information for a specific interface.
show spanning-tree summary display stp summary Display summary information for spanning tree.
show spanning-tree inconsistentports display stp inconsistency Display inconsistent spanning tree ports.
Configuration Commands
spanning-tree mode [MODE] stp mode [MODE] Set the spanning tree mode (e.g., PVST, MST).
spanning-tree vlan [VLAN] priority [PRIORITY] stp instance [INSTANCE_ID] priority [PRIORITY] Set the priority of a spanning tree instance.
`spanning-tree vlan [VLAN] root [PRIMARY SECONDARY] [D1PRIORITY]` stp instance [INSTANCE_ID] priority [PRIORITY]
spanning-tree vlan [VLAN] cost [COST] stp instance [INSTANCE_ID] port cost [COST] Set the port cost for a VLAN.
interface [INTERFACE] interface [INTERFACE] Enter interface configuration mode.
spanning-tree portfast stp edged-port enable Enable PortFast on an interface.
spanning-tree bpduguard stp bpdu-protection enable Enable BPDU guard on an interface.

Leave a Reply

Discover more from Secnetlinux

Subscribe now to keep reading and get access to the full archive.

Continue reading

Discover more from Secnetlinux

Subscribe now to keep reading and get access to the full archive.

Continue reading

Scroll to Top